Sehr häufig verwende ich diese Formel in Excel, um die Anzahl von bestimmten Zelleninhalten zu zählen, oder um einen Teil aus einer Zelle zählen zu können. Vor kurzem habe ich einen kleinen Dienstplan für einen Freund erstellt, in diesem war die Formel wieder sehr wichtig. Aber es gibt ausreichend Anwendungsbeispiele.

ZÄHLENWENN(Bereich;Suchkriterien) Funktion in Excel

Mit dieser Funktionen, können Sie die nichtleeren Zellen eines Bereichs zählen, deren Inhalte mit den Suchkriterien übereinstimmen.

Beispiel:

ZÄHLENWENN Funktion in Excel

ZÄHLENWENN Funktion in Excel

In dieser kleinen Tabelle befinden sich gleich 2 Anwendungsbeispiele für die Formel ZÄHLENWENN(Bereich;Suchkriterien). Ich habe hier aus einem beliebigen Kalenderabschnitt herausfinden wollen, wir häufig die Wochentage vorkommen. Als kleine Hilfe habe ich mir die Wochentage aus dem Datum in einer weiteren Spalte mit der Funktion TEXT(Bereich; „TTTT“) anzeigen lassen. Die Spalte mit den Wochentagen kann ich mir in Excel auch ausblenden, wenn diese Informationen nicht relevant ist – gezählt wird dann aber trotzdem korrekt.

Innerhalb der Funktion habe ich jetzt den Bereich festgelegt und dann gibt es auch hier 3 Möglichkeiten um die Wochentage zu zählen, bzw. um die „Suchkriterien“ zu definieren.

In der Abb. 1 habe ich eine Tabelle erstellt, und den jeweiligen Zelleninhalt, Beispiel: „Montag“ als „Suchkriterien“ verwendet. Wenn wir keine Tabelle verwenden, bzw. keinen Zelleninhalt als Suchkriterium, könnten die Suchkriterien innerhalb der Funktion eingetragen werden.

ZÄHLENWENN (Funktion)

ZÄHLENWENN (Funktion)

ZÄHLENWENN(Bereich;“Montag“)

Wichtig dabei sich die “ “ innerhalb die Suchkriterien eingetragen werden müssen.

Beispiel:

=ZÄHLENWENN($C:$C;“Montag“)

=ZÄHLENWENN($C:$C;G2)

Wenn jetzt innerhalb einer Zelle nach einer Zeichenfolge gesucht werden soll, kann man diese Funktion ebenfalls verwenden. Hier muss die Zeichenfolge innerhalb von ** eingetragen sein. In meinem Beispiel wollte ich wissen, wir häufig im Bereich die Zeichenfolge *tag* vorhanden ist. Das Ergebnis, 12 Mal, und die Funktion dazu lautet =ZÄHLENWENN(Bereich; „*tag*“).

PS: Der Mittwoch ist zwar ein Wochentag, jedoch enthält der „Mittwoch“ die Zeichenfolge *tag* nicht.

ZÄHLENWENN Funktion in Excel: So einfach funktioniert es
Markiert in: